Beta | Page 2 | GTAMotorcycle.com

Beta

Trials

Well-known member
Still searching, theory is a full manual CD might exist and have come with the original machine?
The rectifier (behind headlight) has 4 wires, two are white and i'm getting 17vac on each of those, that indicates the stator outputs are good,
Not seeing 12vdc out of the red and black, if it's not just a bad wire harness connection I suspect cooked diodes. Possibly a short from one of the numerous no longer used wiring connectors.
Bike was stripped for competition by previous owner or dealer so the only appliance the rectifier has to carry is a 12vdc fan. Rider is going to order a new one but I'm wondering if a full wave bridge rectifier and a 12v capacitor wouldn't be as good or better for that task. I think they are looking for about 50 bucks for an OEM rectifier.

Will let y'all know what the fix was once we get it sorted.
 

Trials

Well-known member
Beta is fixed, it was the rectifier (y)

... another rider shattered his front hub :(
and we are looking for a new front tire and fender plastics
and probably a whole bunch more stuff soon.
 

Wingboy

Well-known member
Moderator
Site Supporter
I really don't want to hear about Beta problems....mmkay?
 

Trials

Well-known member
Two more issues today, one Beta that keeps blowing fork seals and a one year old 125cc that had the rear hub completely shatter. Whole bunch of rear hubs have been failing over the last year (3 at least) in a similar fashion.
 

Wingboy

Well-known member
Moderator
Site Supporter
Two more issues today, one Beta that keeps blowing fork seals and a one year old 125cc that had the rear hub completely shatter. Whole bunch of rear hubs have been failing over the last year (3 at least) in a similar fashion.
Sounds scary. Glad i got a good one. Mine is perfect.
 

Trials

Well-known member
Sounds scary. Glad i got a good one. Mine is perfect.
I think you might want to keep an eye on the bolts that hold the sprocket on, make sure they are all torqued down nice and never loosen, that's the only way short of a casting flaw that I can imagine these things are failing like this.
... Owner was lucky enough to have a spare rear wheel from one of the Beta's that dropped into Halifax harbour last year lol.
 

Iceman

Well-known member
Sounds scary. Glad i got a good one. Mine is perfect.
How many hours of runtime on yours now?

Sent from my SM-A530W using Tapatalk
 

Trials

Well-known member
I know where there is a nice one for sale that is slightly beat to a pulp.
Lots of hours.
 

Trials

Well-known member
The one that is for sale will be riding here tomorrow if you want a test ride,
:ROFLMAO: all you have to do to qualify for a test ride is show up on a nicer motorcycle.
 

Top Bottom