New battery did not solve my issue... I need help! | Page 2 | GTAMotorcycle.com

New battery did not solve my issue... I need help!

arogal

Well-known member
hmmm....I'm in the marked for a new used battery.
Friend of mine took battery off my hands. If I still had it I would have given it to you for free. I see why! Because there was never anything wrong with the old battery HAHA!
Sorry
 

arogal

Well-known member
Both the stator and the rectifier are shot. Previous owner replaced with aftermarket parts last summer that costed him $300 for both stator and RR. Iv done some research on the zx6r forums and everyone says stay away from the cheap quality aftermarket stator and RR(more expensive aftermarket like "RICK'S" is ok tho). The OEM parts are really expensive, but it will give me peace of mind and I won't have to do the service again next year.
Also, his friend did the service on his driveway and none of the wires were properly put back together. They were zip tied and tangled rather than being in the correct locations around the fairings and frame.
This wouldn't have hapenned so pre maturely if OEM replacement parts were used.
 

Hyperion

Well-known member
Both the stator and the rectifier are shot. Previous owner replaced with aftermarket parts last summer that costed him $300 for both stator and RR. Iv done some research on the zx6r forums and everyone says stay away from the cheap quality aftermarket stator and RR(more expensive aftermarket like "RICK'S" is ok tho). The OEM parts are really expensive, but it will give me peace of mind and I won't have to do the service again next year.
Also, his friend did the service on his driveway and none of the wires were properly put back together. They were zip tied and tangled rather than being in the correct locations around the fairings and frame.
This wouldn't have hapenned so pre maturely if OEM replacement parts were used.
Just used Ricks Stator and Reg/Rec on my bike, work really well.
 

arogal

Well-known member
Well this sure explains a lot! Thing is toast. Replaced rectifier with OEM also. Previous installation for the stator was a hack job and wasn't even sitting flush in the rotor....glad there wasnt any rotor damage because that would have been another $300 for the part. Bikes running strong again!
 
Last edited:

Top Bottom